首页 > 编程语言 > 详细

python2.7安装numpy报错:is not a supported wheel on...

时间:2015-07-28 19:05:19      阅读:45985      评论:0      收藏:0      [点我收藏+]

标签:class   style   com   http   src   si   文件   la   sp   


python2.7安装numpy时报错信息如下:

C:\Python27\Scripts>pip install "numpy-1.9.2+mkl-cp26-none-win_amd64.whl"
numpy-1.9.2+mkl-cp26-none-win_amd64.whl is not a supported wheel on this platfor
m.

错误原因:

事实上是因为,我的python为2.7版本,下载的numpy为2.6版本,所以错误。

解决方案:

参见:filename.whl is not supported wheel on this platform

技术分享

下载和python对应版本的numpy安装文件:

下载版本为cp27的文件。

技术分享

重新安装运行:

C:\Python27\Scripts>pip install "numpy-1.9.2+mkl-cp26-none-win_amd64.whl"
numpy-1.9.2+mkl-cp26-none-win_amd64.whl is not a supported wheel on this platfor
m.

C:\Python27\Scripts>pip install C:\python-tools\numpy-1.9.2+mkl-cp27-none-win_am
d64.whl
Processing c:\python-tools\numpy-1.9.2+mkl-cp27-none-win_amd64.whl
Installing collected packages: numpy
  Found existing installation: numpy 1.9.2
    Uninstalling numpy-1.9.2:
      Successfully uninstalled numpy-1.9.2
Successfully installed numpy-1.9.2

C:\Python27\Scripts>

成功安装。

在shell中验证安装成功否:

>>> from numpy import *
>>>


python2.7安装numpy报错:is not a supported wheel on...

标签:class   style   com   http   src   si   文件   la   sp   

原文:http://my.oschina.net/HIJAY/blog/484759

(0)
(3)
   
举报
评论 一句话评论(0
0条  
登录后才能评论!
© 2014 bubuko.com 版权所有 鲁ICP备09046678号-4
打开技术之扣,分享程序人生!
             

鲁公网安备 37021202000002号