首页 > 其他 > 详细

LIGHTOJ 1027

时间:2014-03-26 22:42:03      阅读:648      评论:0      收藏:0      [点我收藏+]

应该是概率的题,还有最大公约数约分的问题。

E - LIGHTOJ 1027
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

You are in a maze; seeing n doors in front of you in beginning. You can choose any door you like. The probability for choosing a door is equal for all doors.

If you choose the ith door, it can either take you back to the same position where you begun in xi minutes, or can take you out of the maze after xi minutes. If you come back to the same position, you can‘t remember anything. So, every time you come to the beginning position, you have no past experience.

Now you want to find the expected time to get out of the maze.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a blank line and an integer n (1 ≤ n ≤ 100) denoting the number of doors. The next line contains n space separated integers. If the ith integer (xi) is positive, you can assume that the ith door will take you out of maze after xi minutes. If it‘s negative, then the ith door will take you back to the beginning position after abs(xi) minutes. You can safely assume that 1 ≤ abs(xi) ≤ 10000.

Output

For each case, print the case number and the expected time to get out of the maze. If it‘s impossible to get out of the maze, print ‘inf‘. Print the result in p/q format. Where p is the numerator of the result and q is the denominator of the result and they are relatively prime. See the samples for details.

Sample Input

3

 

1

1

 

2

-10 -3

 

3

3 -6 -9

Sample Output

Case 1: 1/1

Case 2: inf

Case 3: 18/1


#include <stdio.h>
#include <math.h>
#include <string.h>
int gcd(int a,int b)
{
    int r=a%b;
    while(r!=0)
    {
        a=b;
        b=r;
        r=a%b;
    }
    return b;
}
int main()
{
   freopen("input.txt","r",stdin);
   int T;
   scanf("%d",&T);
   int n,sum,n1,t,count=1;
   while(T--)
   {
       scanf("%d",&n);
       sum=0,n1=0;
       while(n--){
        scanf("%d",&t);
        if(t>0){sum+=t;n1++;}
        else sum-=t;
       }
       if(!n1){printf("Case %d: inf\n",count);}
       else{
            int temp=gcd(sum,n1);
            sum/=temp;
            n1/=temp;
            printf("Case %d: %d/%d\n",count,sum,n1);
       }
       count++;
   }
    return 0;
}


LIGHTOJ 1027,布布扣,bubuko.com

LIGHTOJ 1027

原文:http://blog.csdn.net/acvcla/article/details/22206749

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!