首页 > 其他 > 详细

hdu 2818 Building Block

时间:2015-07-29 19:26:01      阅读:216      评论:0      收藏:0      [点我收藏+]

Building Block

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3986    Accepted Submission(s): 1235


Problem Description
John are playing with blocks. There are N blocks (1 <= N <= 30000) numbered 1...N。Initially, there are N piles, and each pile contains one block. Then John do some operations P times (1 <= P <= 1000000). There are two kinds of operation:

M X Y : Put the whole pile containing block X up to the pile containing Y. If X and Y are in the same pile, just ignore this command.
C X : Count the number of blocks under block X

You are request to find out the output for each C operation.
 

Input
The first line contains integer P. Then P lines follow, each of which contain an operation describe above.
 

Output
Output the count for each C operations in one line.
 

Sample Input
6 M 1 6 C 1 M 2 4 M 2 6 C 3 C 4
 

Sample Output
1 0 2
 

Source

2009 Multi-University Training Contest 1 - Host by TJU 

带权并查集

#include<stdio.h>
#include<string.h>
#define M 30000+10
int x[M],rank[M],up[M];//rank记录该点下边有几个点,up记录该点上边有几个 
void init(){
	for(int i=0;i<M;i++){
		x[i]=i; rank[i]=0; up[i]=1; //up初始化为1,以便后边操作 
	}
}
int find(int k){
	int temp=x[k];
	if(x[k]==k) return k;
	x[k]=find(x[k]);
	rank[k]+=rank[temp];//子节点下边的点的个数等于本身的个数加上父节点下边的个数 
	return x[k];
}
void merge(int a,int b)
{
	int fa=find(a);
	int fb=find(b);
	if(fa==fb) return;
	x[fa]=fb;
	rank[fa]=up[fb];//合并时,fa下边几个就等于fb上边有几个因为刚开始初始化为1所以不用再加1 
	up[fb]+=up[fa];//更新 
}
int main()
{
	int p,a,b,c,i;
	char ch[5];
	while(scanf("%d",&p)!=EOF){
		init();
		for(i=0;i<p;i++){
			scanf("%s",ch);
			if(ch[0]=='M'){
				scanf("%d%d",&a,&b);
				merge(a,b);
			}else{
				scanf("%d",&c);
				int k=find(c);
				printf("%d\n",rank[c]);
			}
		}
	}	
	return 0;
} 


hdu 2818 Building Block

原文:http://blog.csdn.net/ling_du/article/details/47130869

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!