首页 > 其他 > 详细

POJ - 2348 Euclid's Game

时间:2015-07-31 20:23:14      阅读:129      评论:0      收藏:0      [点我收藏+]

Description

Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7):
         25 7 
 11 7 
 4 7 
 4 3 
 1 3 
 1 0

an Stan wins.

Input

The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.

Output

For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.

Sample Input

34 12
15 24
0 0

Sample Output

Stan wins
Ollie wins


#include <cstdio>
#include <algorithm>
using namespace std;

int main() {
	int a, b;
	while (scanf("%d%d", &a, &b) && a + b) {
		bool flag = true;
		while (true) {
			if (a > b) swap(a, b);
			if (b % a == 0) break;
			if (b - a > a) break;
			b -= a;
			flag = !flag;
		}
		if (flag) puts("Stan wins");
		else puts("Ollie wins");
	}
	return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

POJ - 2348 Euclid's Game

原文:http://blog.csdn.net/kl28978113/article/details/47174103

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!