首页 > 其他 > 详细

hdu 5224 Tom and Paper

时间:2015-07-31 20:24:24      阅读:228      评论:0      收藏:0      [点我收藏+]

Description

There is a piece of paper in front of Tom, its length and width are integer. Tom knows the area of this paper, he wants to know the minimum perimeter of this paper.
 

Input

In the first line, there is an integer T indicates the number of test cases. In the next T lines, there is only one integer n in every line, indicates the area of paper. 
技术分享技术分享技术分享技术分享技术分享技术分享技术分享技术分享技术分享技术分享
 

Output

For each case, output a integer, indicates the answer.
 

Sample Input

3 2 7 12
 

Sample Output

6 16 14
 
题意:
输入一张矩形纸的面积,求出其最小周长。
思路:
直接暴力求解,如果用两重循环,会超时,换成一重循环则不会。
代码:
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
int main()
{
    int T;
    int n;
    double x;
    int y;
    scanf("%d",&T);
    while(T--)
    {
        int   ans=2*1000000000;
        scanf("%d",&n);
        x=sqrt(n);
        for(int i=1;i<=x;i++)
        {
           if(n%i==0)
           {
               y=n/i;
               ans=min(ans,2*(i+y));
           }

        }

         printf("%d\n",ans);



    }
    return 0 ;
}

 
 
 
 
 
 
 
 

版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu 5224 Tom and Paper

原文:http://blog.csdn.net/a1967919189/article/details/47173955

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!