首页 > 其他 > 详细

HDU 5375 Gray code(模拟)

时间:2015-08-11 18:39:30      阅读:156      评论:0      收藏:0      [点我收藏+]

Gray code

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 65    Accepted Submission(s): 35


Problem Description
The reflected binary code, also known as Gray code after Frank Gray, is a binary numeral system where two successive values differ in only onebit (binary digit). The reflected binary code was originally designed to prevent spurious output from electromechanical switches. Today, Gray codes are widely used to facilitate error correction in digital communications such as digital terrestrial television and some cable TV systems.

技术分享


Now , you are given a binary number of length n including ‘0’ , ’1’ and ‘?’(? means that you can use either 0 or 1 to fill this position) and n integers(a1,a2,….,an) . A certain binary number corresponds to a gray code only. If the ith bit of this gray code is 1,you can get the point ai.
Can you tell me how many points you can get at most?

For instance, the binary number “00?0” may be “0000” or “0010”,and the corresponding gray code are “0000” or “0011”.You can choose “0000” getting nothing or “0011” getting the point a3 and a4.
 

Input
The first line of the input contains the number of test cases T.

Each test case begins with string with ‘0’,’1’ and ‘?’.

The next line contains n (1<=n<=200000) integers (n is the length of the string).

a1 a2 a3 … an (1<=ai<=1000)
 

Output
For each test case, output “Case #x: ans”, in which x is the case number counted from one,’ans’ is the points you can get at most
 

Sample Input
2 00?0 1 2 4 8 ???? 1 2 4 8
 

Sample Output
Case #1: 12 Case #2: 15
Hint
https://en.wikipedia.org/wiki/Gray_code http://baike.baidu.com/view/358724.htm
 

Source
 




#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<stack>
#include<queue>
#include<map>

#define eps 1e-6
#define INF 0x3f3f3f3f

using namespace std;

char str[200010];
int a[200100];

int main()
{
    int T;
    scanf("%d",&T);
    int k = 0;
    while(T--)
    {
        scanf("%s",str);
        int n = strlen(str);
        int p = 0;
        int pi = 0;
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
        }
        int flag = 0;
        int sum = 0;
        int minn = 99999;
        int cnt = 0;
        if(str[0] !='?')
        {
            p = str[0] - '0';
            pi = 0;
            if(str[0] == '1')
            {
                sum += a[0];
            }
        }
        else
        {
            for(int j=0; j<n; j++)
            {
                if(str[j]!='?')
                {
                    p = str[j] - '0';
                    sum += a[j];
                    pi = j;
                    minn = min(minn,a[j]);
                    break;
                }
                else
                {
                    cnt++;
                    sum += a[j];
                    minn = min(minn,a[j]);
                }
            }
            if(cnt == n)
            {
                flag = 1;
                printf("Case #%d: %d\n",++k,sum);
                break;
            }
            if(cnt%2 == 1 && p == 1)
            {
                sum = sum - minn;
            }
            else if(cnt%2 == 0 && p == 0)
            {
                sum = sum - minn;
            }
        }
        int pp,pj;
        if(flag == 0)
        {
            for(int i=pi+1;i<n;)
            {
                if(str[i]!='?')
                {
                    if(str[i-1]!='?' && str[i] != str[i-1])
                    {
                        sum += a[i];
                        p = str[i] - '0';
                        pi = i;
                    }
                    i++;
                    continue;
                }
                minn = 99999;
                cnt = 0;
                while(str[i] == '?')
                {
                    sum += a[i];
                    minn = min(minn,a[i]);
                    i++;
                    cnt++;
                    if(i==n)
                    {
                        break;
                    }
                }
                if(i<n)
                {
                    sum += a[i];
                    minn = min(minn,a[i]);
                    pp = str[i] - '0';
                    pj = i;
                    if(p!=pp && cnt%2 == 1)
                    {
                        sum -= minn;
                    }
                    else if(p == pp && cnt%2 == 0)
                    {
                        sum -= minn;
                    }
                    p = pp;
                    pi = pj;
                }
            }
            printf("Case #%d: %d\n",++k,sum);
        }
    }
    return 0;
}


版权声明:本文为博主原创文章,如有特殊需要请与博主联系 QQ : 793977586。

HDU 5375 Gray code(模拟)

原文:http://blog.csdn.net/yeguxin/article/details/47424595

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!