首页 > 其他 > 详细

Hdu_1003_Max Sum 解题心得

时间:2015-08-15 18:09:06      阅读:202      评论:0      收藏:0      [点我收藏+]

原题:

Description

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14. 
 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000). 
 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases. 
 

Sample Input

2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output

Case 1: 14 1 4 Case 2: 7 1 6
 
分析:
求最大字段和,d[i]表示已 i 结尾(字段和中包含 i )在 a[1..i] 上的最大和,d[i]=(d[i-1]+a[i]>a[i])?d[i-1]+a[i]:a[i];
max = {d[i],1<=i<=n} 这就是状态转移方程
 
 
代码:
#include <iostream>  
#include<cstdio>
using namespace std;
int main()
{
    int j, i, k, n, m, t;
    int a;
    scanf("%d", &t);
    for (j = 1; j <= t; j++)
    {
        scanf("%d", &n);
        int sum = 0, maxsum = -1001, first = 0, last = 0, temp = 1;
        for (i = 0; i<n; i++)
        {
            scanf("%d", &a);
            sum += a;
            if (sum > maxsum)
            {
                maxsum = sum; first = temp; last = i + 1;
            }
            if (sum < 0)
            {
                sum = 0; temp = i + 2;
            }
        }
        printf("Case %d:\n%d %d %d\n", j, maxsum, first, last);
        if (j != t)
        {
            printf("\n");
        }
    }

    return 0;
}

 

 

Hdu_1003_Max Sum 解题心得

原文:http://www.cnblogs.com/shawn-ji/p/4732758.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!