首页 > 其他 > 详细

POJ 3009 Curling 2.0 求解!

时间:2014-03-29 06:48:29      阅读:391      评论:0      收藏:0      [点我收藏+]


Description

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.

bubuko.com,布布扣
Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

  • At the beginning, the stone stands still at the start square.
  • The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
  • When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
  • Once thrown, the stone keeps moving to the same direction until one of the following occurs:
    • The stone hits a block (Fig. 2(b), (c)).
      • The stone stops at the square next to the block it hit.
      • The block disappears.
    • The stone gets out of the board.
      • The game ends in failure.
      • The stone reaches the goal square.
        • The stone stops there and the game ends in success.
      • You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.
      • bubuko.com,布布扣
        Fig. 2: Stone movements

        Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

        With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).

        bubuko.com,布布扣
        Fig. 3: The solution for Fig. D-1 and the final board configuration

        Input

        The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

        Each dataset is formatted as follows.

        the width(=w) and the height(=h) of the board
        First row of the board

        ...
        h-th row of the board

        The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

        Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

        0 vacant square
        1 block
        2 start position
        3 goal position

        The dataset for Fig. D-1 is as follows:

        6 6
        1 0 0 2 1 0 
        1 1 0 0 0 0
        0 0 0 0 0 3
        0 0 0 0 0 0
        1 0 0 0 0 1
        0 1 1 1 1 1

        Output

        For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

        Sample Input

        2 1
        3 2
        6 6
        1 0 0 2 1 0
        1 1 0 0 0 0
        0 0 0 0 0 3
        0 0 0 0 0 0
        1 0 0 0 0 1
        0 1 1 1 1 1
        6 1
        1 1 2 1 1 3
        6 1
        1 0 2 1 1 3
        12 1
        2 0 1 1 1 1 1 1 1 1 1 3
        13 1
        2 0 1 1 1 1 1 1 1 1 1 1 30 0

        Sample Output

        1
        4
        -1
        4
        10
        -1
      • 这题目我错到吐,一直wa,后来看网上要把输入数组清零,可我不明白这是为什么,如果不清0会覆盖写入,m和n都是规定好界的,而且会有判断是否出界,实在搞不懂为啥要清零,还有一个wa的原因就是要求先输入列数,再输入行数,我输入反了。。。可就是这么巧,给的样例正反输出恰好都一样!唉,下次读题要仔细。。
      • #include<stdio.h>
        #include<string.h>
        int n,m,ans;
        int mat[25][25];
        int dx[4]={-1,0,1,0};
        int dy[4]={0,1,0,-1};
        int ok(int x,int y)
        {
            if(x>=1 && x<=n && y>=1 && y<=m)
                return 1;
            return 0;
        }
        void dfs(int x,int y,int cur)
        {
            if(cur>=10) return;
            for(int i=0;i<4;i++)
            {
                int nx=x+dx[i];
                int ny=y+dy[i];
                if(ok(nx,ny) && mat[nx][ny]!=1)
                {
                    while(ok(nx,ny) && mat[nx][ny]!=1 && mat[nx][ny]!=3)
                    {
                        nx+=dx[i];
                        ny+=dy[i];
                    }
                    if(mat[nx][ny]==3)
                    {
                        if(ans>cur+1)
                            ans=cur+1;
                        return;
                    }
                    else if(mat[nx][ny]==1)
                    {
                        mat[nx][ny]=0;
                        dfs(nx-dx[i],ny-dy[i],cur+1);
                        mat[nx][ny]=1;
                    }
                }
            }
        }
        int main()
        {
            while(~scanf("%d%d",&m,&n))
            {
                if(n==0 && m==0 ) break;
                memset(mat,0,sizeof(mat));
                int i,j,sx,sy;
                for(i=1; i<=n; i++)
                    for(j=1; j<=m; j++)
                    {
                        scanf("%d",&mat[i][j]);
                        if(mat[i][j]==2)
                        {
                            sx=i;sy=j;
                        }
                    }
                ans=500;
                dfs(sx,sy,0);
                if(ans<11) printf("%d\n",ans);
                else printf("-1\n");
            }
            return 0;
        }
        

POJ 3009 Curling 2.0 求解!,布布扣,bubuko.com

POJ 3009 Curling 2.0 求解!

原文:http://blog.csdn.net/u013923947/article/details/22455221

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!