首页 > 其他 > 详细

HDU Wolf and Rabbit

时间:2015-08-21 22:52:38      阅读:225      评论:0      收藏:0      [点我收藏+]

Description

There is a hill with n holes around. The holes are signed from 0 to n-1. 

技术分享


A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes. 
 

Input

The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648). 
 

Output

For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line. 
 

Sample Input

2
1 2
2 2

Sample Output

NO
YES
 
 题意:
有n个洞 0。。n-1;
狼从0开始每m个洞进去一次 
问兔子是否存活,
其实就是判断n,m的最大公约数是否为1
仔细想想吧
技术分享
#include<iostream>
using namespace std;
int gcd(int a,int b){
    return b==0?a:gcd(b,a%b);
}
int main(){
    int t,n,m;cin>>t;
    while(t--){
        cin>>m>>n;
        if(m==1)cout<<"NO"<<endl;
        else {
            if(gcd(n,m)==1)cout<<"NO"<<endl;
            else cout<<"YES"<<endl;
        }
    }
return 0;
}
View Code

 

 
 

HDU Wolf and Rabbit

原文:http://www.cnblogs.com/demodemo/p/4749047.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!