首页 > 其他 > 详细

LightOJ 1104 Birthday Paradox

时间:2015-08-21 23:07:38      阅读:265      评论:0      收藏:0      [点我收藏+]

Description

Sometimes some mathematical results are hard to believe. One of the common problems is the birthday paradox. Suppose you are in a party where there are 23 people including you. What is the probability that at least two people in the party have same birthday? Surprisingly the result is more than 0.5. Now here you have to do the opposite. You have given the number of days in a year. Remember that you can be in a different planet, for example, in Mars, a year is669 days long. You have to find the minimum number of people you have to invite in a party such that the probability of at least two people in the party have same birthday is at least 0.5.

Input

Input starts with an integer T (≤ 20000), denoting the number of test cases.

Each case contains an integer n (1 ≤ n ≤ 105) in a single line, denoting the number of days in a year in the planet.

Output

For each case, print the case number and the desired result.

Sample Input

2

365

669

Sample Output

Case 1: 22

Case 2: 30

 

题意:

假设一年有n天,你要找你的朋友来参加party,且要求至少有两个人生日相同的概率大于等于0.5的最少人数,这个就是你要邀请的最小人数。

 

就是暴力啊  一个一个邀请算概率

 太水了没甚么好说的~~~~

 

 

技术分享
#include<iostream>
using namespace std;
int main(){
    int t,i,k=1;cin>>t;
    double p ,n;
    while(t--){
        i=0;p=1;
        cin>>n;
        while(p>0.5){
            i++;
            p*=(n-i)/n;
        }
        cout<<"Case "<<k++<<": "<<i<<endl;
    }
return 0;
}
View Code

 

LightOJ 1104 Birthday Paradox

原文:http://www.cnblogs.com/demodemo/p/4749040.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!