首页 > 其他 > 详细

Box of Bricks

时间:2015-08-28 13:29:35      阅读:211      评论:0      收藏:0      [点我收藏+]

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5871    Accepted Submission(s): 2549


Problem Description
Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. ``Look, I‘ve built a wall!‘‘, he tells his older sister Alice. ``Nah, you should make all stacks the same height. Then you would have a real wall.‘‘, she retorts. After a little con- sideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help?

技术分享

 

Input
The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1 <= n <= 50 and 1 <= hi <= 100.

The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.

The input is terminated by a set starting with n = 0. This set should not be processed.
 

Output
For each set, first print the number of the set, as shown in the sample output. Then print the line ``The minimum number of moves is k.‘‘, where k is the minimum number of bricks that have to be moved in order to make all the stacks the same height.

Output a blank line after each set.
 

Sample Input
6 5 2 4 1 7 5 0
 

Sample Output
Set #1 The minimum number of moves is 5.
没有注意输出的结尾还有一个‘.‘技术分享
#include<stdio.h>
int main()
{
	int n,j=0;
	while(scanf("%d",&n),n)
	{
		int x[1000],sum=0,s=0;
		for(int i=0;i<n;i++)
		{
			scanf("%d",&x[i]);
			sum+=x[i];
		}
		for(int i=0;i<n;i++)
		if(sum/n<x[i])
		s+=x[i]-sum/n;
		printf("Set #%d\nThe minimum number of moves is %d.\n\n",++j,s);
	}
	return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

Box of Bricks

原文:http://blog.csdn.net/l15738519366/article/details/48048185

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!