首页 > 其他 > 详细

poj 1821 Fence(单调队列+dp)

时间:2015-08-29 23:22:18      阅读:301      评论:0      收藏:0      [点我收藏+]

Language:
Fence
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 4161   Accepted: 1288

Description

A team of k (1 <= K <= 100) workers should paint a fence which contains N (1 <= N <= 16 000) planks numbered from 1 to N from left to right. Each worker i (1 <= i <= K) should sit in front of the plank Si and he may paint only a compact interval (this means that the planks from the interval should be consecutive). This interval should contain the Si plank. Also a worker should not paint more than Li planks and for each painted plank he should receive Pi $ (1 <= Pi <= 10 000). A plank should be painted by no more than one worker. All the numbers Si should be distinct. 

Being the team‘s leader you want to determine for each worker the interval that he should paint, knowing that the total income should be maximal. The total income represents the sum of the workers personal income. 

Write a program that determines the total maximal income obtained by the K workers. 

Input

The input contains: 
Input 

N K 
L1 P1 S1 
L2 P2 S2 
... 
LK PK SK 

Semnification 

N -the number of the planks; K ? the number of the workers 
Li -the maximal number of planks that can be painted by worker i 
Pi -the sum received by worker i for a painted plank 
Si -the plank in front of which sits the worker i 

Output

The output contains a single integer, the total maximal income.

Sample Input

8 4
3 2 2
3 2 3
3 3 5
1 1 7 

Sample Output

17

Hint

Explanation of the sample: 

the worker 1 paints the interval [1, 2]; 

the worker 2 paints the interval [3, 4]; 

the worker 3 paints the interval [5, 7]; 

the worker 4 does not paint any plank 

Source




#pragma comment(linker, "/STACK:1024000000,1024000000")
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<set>
#include<map>

#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)

#define bug printf("hihi\n")

#define eps 1e-8
typedef __int64 ll;

using namespace std;

#define N 16005
int dp[105][N];

struct stud{
  int len,pos,price;
  bool operator <(const stud b) const
  {
      return pos<b.pos;
  }
}f[N];

int n,len;
int que[N];
int tail,head;

void solve()
{
    int i,j;
    memset(dp,0,sizeof(dp));
    for(i=1;i<=n;i++)
    {
        for(int j=0;j<=len;j++)
            dp[i][j]=dp[i-1][j];

        int le,pos,price;
        le=f[i].len;
        pos=f[i].pos;
        price=f[i].price;
        head=tail=0;
        for(j=0;j<=len;j++)
        {
            if(pos+le<=j) break;
            if(j<pos)
            {
                int temp=dp[i-1][j]-j*price;
                while(head<tail&&dp[i-1][que[tail-1]]-que[tail-1]*price<temp)
                    tail--;
                que[tail++]=j;
                continue;
            }
            while(head<tail&&que[head]+le<j) head++;
            dp[i][j]=max(dp[i][j],dp[i-1][que[head]]-que[head]*price+j*price);
        }
        for(j=1;j<=len;j++)
            dp[i][j]=max(dp[i][j],dp[i][j-1]);
    }
    printf("%d\n",dp[n][len]);
}

int main()
{
    int i,j;
    while(~scanf("%d%d",&len,&n))
    {
        for(i=1;i<=n;i++)
            scanf("%d%d%d",&f[i].len,&f[i].price,&f[i].pos);
        sort(f+1,f+n+1);
        solve();
    }
    return 0;
}






版权声明:本文为博主原创文章,未经博主允许不得转载。

poj 1821 Fence(单调队列+dp)

原文:http://blog.csdn.net/u014737310/article/details/48092331

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!