首页 > 其他 > 详细

USACO 1.2 Palindromic Squares

时间:2015-09-01 23:57:03      阅读:437      评论:0      收藏:0      [点我收藏+]
Palindromic Squares
Rob Kolstad

Palindromes are numbers that read the same forwards as backwards. The number 12321 is a typical palindrome.

Given a number base B (2 <= B <= 20 base 10), print all the integers N (1 <= N <= 300 base 10) such that the square of N is palindromic when expressed in base B; also print the value of that palindromic square. Use the letters ‘A‘, ‘B‘, and so on to represent the digits 10, 11, and so on.

Print both the number and its square in base B.

PROGRAM NAME: palsquare

INPUT FORMAT

A single line with B, the base (specified in base 10).

SAMPLE INPUT (file palsquare.in)

10

OUTPUT FORMAT

Lines with two integers represented in base B. The first integer is the number whose square is palindromic; the second integer is the square itself. NOTE WELL THAT BOTH INTEGERS ARE IN BASE B!

SAMPLE OUTPUT (file palsquare.out)

1 1
2 4
3 9
11 121
22 484
26 676
101 10201
111 12321
121 14641
202 40804
212 44944
264 69696

题解 :简单题 进制转换,然后判断是否是回文数

 

 

/*
ID: cxq_xia1
PROG: palsquare
LANG: C++
*/

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int B;
char trans[20]={‘0‘,‘1‘,‘2‘,‘3‘,‘4‘,‘5‘,‘6‘,‘7‘,‘8‘,‘9‘,‘A‘,‘B‘,‘C‘,‘D‘,‘E‘,‘F‘,‘G‘,‘H‘,‘I‘,‘J‘};
char ans1[25],ans2[50];
int cntLen1,cntLen2;
bool isPalsquare(char a[],int n)
{
    for(int i=0;i<n;i++)
    {
        if(a[i]!=a[n-1-i])
            return false;
    }
    return true;
}
void output()
{
    for(int i=cntLen1-1;i>=0;i--)
        cout << ans1[i];
    cout << " ";

    for(int i=cntLen2-1;i>=0;i--)
        cout << ans2[i];
    cout << endl;
}
int main()
{
    freopen("palsquare.in","r",stdin);
    freopen("palsquare.out","w",stdout);

    cin >> B;
    for(int i=1;i<=300;i++)
    {
        cntLen1=0;cntLen2=0;
        memset(ans1,0,sizeof(ans1));
        memset(ans2,0,sizeof(ans2));
        int tmp1,tmp2;
        tmp1=i;
        while(tmp1!=0)
        {
            ans1[cntLen1++]=trans[tmp1%B];
            tmp1/=B;
        }

        tmp2=i*i;
        while(tmp2!=0)
        {
            ans2[cntLen2++]=trans[tmp2%B]
            ;
            tmp2/=B;
        }

        if(isPalsquare(ans2,cntLen2))
        {
            output();
        }
    }
    return 0;
}

  

 

USACO 1.2 Palindromic Squares

原文:http://www.cnblogs.com/WillsCheng/p/4776924.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!