首页 > 其他 > 详细

hdu 5327 Olympiad

时间:2015-09-10 00:24:30      阅读:255      评论:0      收藏:0      [点我收藏+]

题目连接

http://acm.hdu.edu.cn/showproblem.php?pid=5327   

Olympiad

Description

You are one of the competitors of the Olympiad in numbers. The problem of this year relates to beatiful numbers. One integer is called beautiful if and only if all of its digitals are different (i.e. 12345 is beautiful, 11 is not beautiful and 100 is not beautiful). Every time you are asked to count how many beautiful numbers there are in the interval $[a,b]\ (a \le b)$. Please be fast to get the gold medal!

Input

The first line of the input is a single integer $T\ (T \leq 1000)$, indicating the number of testcases.

For each test case, there are two numbers $a$ and $b$, as described in the statement. It is guaranteed that $1 \leq a \leq b \leq 100000$.

Output

For each testcase, print one line indicating the answer. 

Sample Input

2
1 10
1 1000

Sample Output

10
738

暴力枚举,前缀和。。

#include<algorithm>
#include<iostream>
#include<cstdlib>
#include<cstring>
#include<cstdio>
#include<vector>
#include<map>
using std::map;
using std::min;
using std::find;
using std::pair;
using std::vector;
using std::multimap;
#define pb(e) push_back(e)
#define sz(c) (int)(c).size()
#define mp(a, b) make_pair(a, b)
#define all(c) (c).begin(), (c).end()
#define iter(c) __typeof((c).begin())
#define cls(arr, val) memset(arr, val, sizeof(arr))
#define cpresent(c, e) (find(all(c), (e)) != (c).end())
#define rep(i, n) for(int i = 0; i < (int)n; i++)
#define tr(c, i) for(iter(c) i = (c).begin(); i != (c).end(); ++i)
const int N = 100001;
const int INF = 0x3f3f3f3f;
int vis[10], sum[N + 10];
void init() {
    int v, j;
    sum[0] = 0;
    for(int i = 1; i <= N; i++) {
        v = i;
        bool f = true;
        cls(vis, 0);
        do vis[v % 10]++; while(v /= 10);
        for(j = 0; j < 10; j++) {
            if(vis[j] > 1) { f = false; break;}
        }
        sum[i] = sum[i - 1] + f;
    }
}
int main() {
#ifdef LOCAL
    freopen("in.txt", "r", stdin);
    freopen("out.txt", "w+", stdout);
#endif
    init();
    int t, x, y;
    scanf("%d", &t);
    while(t--) {
        scanf("%d %d", &x, &y);
        printf("%d\n", sum[y] - sum[x - 1]);
    }
    return 0;
}

hdu 5327 Olympiad

原文:http://www.cnblogs.com/GadyPu/p/4796277.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!