首页 > 其他 > 详细

POJ 3252 数位dp

时间:2014-04-04 22:23:06      阅读:603      评论:0      收藏:0      [点我收藏+]
Round Numbers
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 8153   Accepted: 2847

Description

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone‘ (also known as ‘Rock, Paper, Scissors‘, ‘Ro, Sham, Bo‘, and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can‘t even flip a coin because it‘s so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively Start and Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive range Start..Finish

Sample Input

2 12

Sample Output

6


求区间内二进制里0的个数比1多的数有多少个。就是计算[1,A-1],[1,B-1]区间内的round number,然后做差即可,dp[pos][num0][num1]表示到第pos位0的个数为num0,1的个数为num1的数有多少个,然后数位dp。

代码:

/* ***********************************************
Author :rabbit
Created Time :2014/4/4 13:48:30
File Name :10.cpp
************************************************ */
#pragma comment(linker, "/STACK:102400000,102400000")
#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <sstream>
#include <stdlib.h>
#include <string.h>
#include <limits.h>
#include <string>
#include <time.h>
#include <math.h>
#include <queue>
#include <stack>
#include <set>
#include <map>
using namespace std;
#define INF 0x3f3f3f3f
#define eps 1e-8
#define pi acos(-1.0)
typedef long long ll;
const int maxn=40;
int dp[maxn][maxn][maxn],num[maxn];
int dfs(int pos,int num0,int num1,bool flag,bool first){
	if(pos==0)return num0>=num1;
	if(flag&&dp[pos][num0][num1]!=-1)return dp[pos][num0][num1];
	int ans=0,end=flag?1:num[pos];
	for(int i=0;i<=end;i++)
		ans+=dfs(pos-1,(!first&&i==0)?0:num0+(i==0),(!first&&i==0)?0:num1+(i==1),flag||i<end,first||i==1);
	if(flag)dp[pos][num0][num1]=ans;
	return ans;
}
int calc(int n){
    int pos=0;
    while(n)num[++pos]=n&1,n>>=1;
    return dfs(pos,0,0,0,0);
}
int main(){
    int l,r;
    memset(dp,-1,sizeof(dp));
    while(~scanf("%d%d",&l,&r))printf("%d\n",calc(r)-calc(l-1));
    return 0;
}



POJ 3252 数位dp,布布扣,bubuko.com

POJ 3252 数位dp

原文:http://blog.csdn.net/xianxingwuguan1/article/details/22935029

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!