首页 > 其他 > 详细

hdu5505 GT and numbers(BestCoder Round #60)

时间:2015-10-18 23:16:08      阅读:503      评论:0      收藏:0      [点我收藏+]

GT and numbers

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 262 Accepted Submission(s): 75


Problem Description
You are given two numbers N技术分享 and M技术分享.

Every step you can get a new N技术分享 in the way that multiply N技术分享 by a factor of N技术分享.

Work out how many steps can N技术分享 be equal to M技术分享 at least.

If N can‘t be to M forever,print ?1技术分享.

Input
In the first line there is a number T技术分享.T技术分享 is the test number.

In the next T技术分享 lines there are two numbers N技术分享 and M技术分享.

T1000技术分享, 1N1000000技术分享,1M2技术分享63技术分享技术分享.

Be careful to the range of M.

You‘d better print the enter in the last line when you hack others.

You‘d better not print space in the last of each line when you hack others.

Output
For each test case,output an answer.

Sample Input
3 1 1 1 2 2 4

Sample Output
0 -1 1

Source

题意:每个n都可以乘上一个自己的因子,求最少乘几次能得到m。
分析:

如果AAA大于BBB那么显然无解。

考虑把AAABBB分解质因数。

BBB存在AAA没有的质因数也显然无解。

对于某一个AAA的质因数的次数。为了加速接近BBB,它一定是每次翻倍,最后一次的时候把剩下的加上。

那么答案就是最小的kkk使得2k?Anum≥Bnum2^{k}*A_{num} \geq B_{num}2?k???A?num??B?num??

最后把每个质因数的答案max起来即可。(B可以是2^63,这样就得用unsigned long long了,这是个坑点)

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long
#define CL(a) memset(a,0,sizeof(a))

unsigned ll n,m;

ll gcd(ll a, ll b)
{
    if(a%b)
        return gcd(b, a%b);
    return b;
}

int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        cin>>n>>m;
        int ans=0;
        while(n!=m)
        {
            if(m%n){cout<<"-1"<<endl; break;}
            ll k=gcd(m/n, n);
            if(k==1){cout<<"-1"<<endl; break;}
            n*=k;
            ans++;
        }
        if(n==m) cout<<ans<<endl;
    }
    return 0;
}


2632^{63这样就要开unsigned long long。

版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu5505 GT and numbers(BestCoder Round #60)

原文:http://blog.csdn.net/d_x_d/article/details/49227637

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!