首页 > 其他 > 详细

HDU-1142-A Walk Through the Forest(Dijkstra+dfs)

时间:2014-04-06 01:59:58      阅读:511      评论:0      收藏:0      [点我收藏+]
Problem Description
Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his house is on the other. A nice walk through the forest, seeing the birds and chipmunks is quite enjoyable.
The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take.
 

Input
Input contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives the number of intersections N, 1 < N ≤ 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 ≤ d ≤ 1000000 indicating a path of length d between intersection a and a different intersection b. Jimmy may walk a path any direction he chooses. There is at most one path between any pair of intersections.
 

Output
For each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647
 

Sample Input
5 6 1 3 2 1 4 2 3 4 3 1 5 12 4 2 34 5 2 24 7 8 1 3 1 1 4 1 3 7 1 7 4 1 7 5 1 6 7 1 5 2 1 6 2 1 0
 

Sample Output
2 4
 
题意:从1(起点)出发,每一次都选离2(终点)更近的路走,求一直这么走到终点共有几种走法。

思路:先求出所有点到终点的最小距离,再用dfs求所有走法的种数。

#include <stdio.h>
#define INF 99999999

int d[1001],map[1001][1001],vis[1001],n;

int dfs(int x)//直接普通的dfs会超时,要把走过的点的结果保存下来
{
    if(x==2) return 1;//终点,返回1

    if(vis[x]) return vis[x];//如果已经走过,直接返回结果

    for(int i=2;i<=n;i++)//如果没走过,就dfs,并把结果保存下来再返回
    {
        if(map[x][i]<INF && d[x]>d[i])
        {
            vis[x]+=dfs(i);
        }
    }

    return vis[x];
}

int main()
{
    int m,i,j,a,b,c,minnum,minindex,t;

    while(~scanf("%d%d",&n,&m) && n)
    {
        for(i=1;i<=n;i++) d[i]=INF,vis[i]=0;
        for(i=1;i<=n;i++) for(j=1;j<=n;j++) map[i][j]=INF;

        while(m--)
        {
            scanf("%d%d%d",&a,&b,&c);

            if(map[a][b]>c) map[a][b]=map[b][a]=c;
        }
        
        
        //Dijkstra求出所有点到终点的最小距离
        d[2]=0;

        t=n-1;
        while(t--)
        {
            minnum=INF;
            for(i=1;i<=n;i++)
            {
                if(!vis[i] && d[i]<minnum)
                {
                    minnum=d[i];
                    minindex=i;
                }
            }

            vis[minindex]=1;

            for(i=1;i<=n;i++)
            {
                if(!vis[i] && d[i]>d[minindex]+map[minindex][i])
                {
                    d[i]=d[minindex]+map[minindex][i];
                }
            }
        }

        for(i=1;i<=n;i++) vis[i]=0;//这里用来保存dfs过程中每个点的结果

        printf("%d\n",dfs(1));
    }
}


HDU-1142-A Walk Through the Forest(Dijkstra+dfs),布布扣,bubuko.com

HDU-1142-A Walk Through the Forest(Dijkstra+dfs)

原文:http://blog.csdn.net/faithdmc/article/details/22998705

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!