首页 > 其他 > 详细

hdu1212 Big Number

时间:2014-04-06 02:50:35      阅读:563      评论:0      收藏:0      [点我收藏+]

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4376    Accepted Submission(s): 3014


Problem Description
As we know, Big Number is always troublesome. But it‘s really important in our ACM. And today, your task is to write a program to calculate A mod B.

To make the problem easier, I promise that B will be smaller than 100000.

Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.
 

Input
The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.
 

Output
For each test case, you have to ouput the result of A mod B.
 

Sample Input
2 3 12 7 152455856554521 3250
 

Sample Output
2 5 1521
 



//============================================================================
// Name        : Math_hdu1212.cpp
// Author      : vit
// Version     :
// Copyright   : Your copyright notice
// Description : Hello World in C++, Ansi-style
//============================================================================

#include <iostream>
#include <stdio.h>
#include <string.h>

using namespace std;

int mod(char *a,int b)//模拟手算
{
    int tmp=0;
    int len=strlen(a);
    for(int i=0; i<len; i++)
    {
        tmp=tmp*10+a[i]-‘0‘;
        tmp=tmp%b;
    }
    return tmp;
}

char a[1001];
int main() {
	int b;
	while(cin >> a >> b){
		cout << mod(a , b) << endl;
	}
	return 0;
}


hdu1212 Big Number,布布扣,bubuko.com

hdu1212 Big Number

原文:http://blog.csdn.net/svitter/article/details/22998641

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!