首页 > 其他 > 详细

BestCoder Round #61 1002 Game

时间:2015-10-31 22:53:24      阅读:335      评论:0      收藏:0      [点我收藏+]
Problem Description

XY is playing a game:there are N pillar in a row,which numbered from 1 to n.Each pillar has a jewel.Now XY is standing on the S-th pillar and the exit is in the T-th pillar.XY can leave from the exit only after they get all the jewels.Each time XY can move to adjacent pillar,or he can jump to boundary ( the first pillar or the N-th pillar) by using his superpower.However,he needs to follow a rule:if he left the pillar,he no can not get here anymore.In order to save his power,XY wants to use the minimum number of superpower to pass the game.

Input

There are multiple test cases, no more than 1000 cases. For each case,the line contains three integers:N,S and T.(1≤N≤10000,1≤S,T≤N)(1\leq N\leq10000,1\leq S,T\leq N )(1N10000,1S,TN)

Output

The output of each case will be a single integer on a line: the minimum number of using superpower or output -1 if he can‘t leave.

Sample Input
4 1 4
4 1 3
Sample Output
0
1


各种情况想到就好,好多人哭晕在厕所23333
无解的情况只有起点和终点位置一样且N不为1。终点和起点都在边界上答案为0,如果起点在边界上或者起点终点相邻答案为1,其他答案为2.
技术分享
#include <iostream>
#include <cmath>
using namespace std;
int main()
{
    int N,S,T;
    while(cin>>N>>S>>T){
        if(S==T && N!=1) cout<<"-1"<<endl;
        else if(abs(S-T)+1==N) cout<<"0"<<endl;
        else if((T==N || T==1) && abs(S-T)!=1) cout<<"2"<<endl;
        else if(S==1 || S==N || abs(S-T)==1) cout<<"1"<<endl;
        else cout<<"2"<<endl;
    }
    return 0;
}
View Code
技术分享
#include<iostream>
#include<stdio.h>
using namespace std;
int main()
{
    freopen("in.txt","r",stdin);
    int n,s,t;
    while(~scanf("%d%d%d",&n,&s,&t))
    {
        if(n==1){cout<<"0\n";goto k;}
        if(s==1&&t==n){cout<<"0\n";goto k;}
        if(n==1&&t==s){cout<<"0\n";goto k;}
        if(s==t){cout<<"-1\n";goto k;}
        if(n==3){cout<<"0\n";goto k;}
        if(t+1==s){cout<<"1\n";goto k;}
        if(s+1==t){cout<<"1\n";goto k;}
        if(t==1||t==n){cout<<"2\n";goto k;}
        if(s==1||s==n){cout<<"1\n";goto k;}
        else cout<<"2\n";
        k: n=s=t=0;
    }
    return 0;
}
View Code

 

BestCoder Round #61 1002 Game

原文:http://www.cnblogs.com/dzzy/p/4926353.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!