首页 > 其他 > 详细

ACM-DFS之Kill The Monster——hdu2616

时间:2014-04-07 19:47:50      阅读:656      评论:0      收藏:0      [点我收藏+]
Kill the monster
题目:http://acm.hdu.edu.cn/showproblem.php?pid=2616
Problem Description
There is a mountain near yifenfei’s hometown. On the mountain lived a big monster. As a hero in hometown, yifenfei wants to kill it.
Now we know yifenfei have n spells, and the monster have m HP, when HP <= 0 meaning monster be killed. Yifenfei’s spells have different effect if used in different time. now tell you each spells’s effects , expressed (A ,M). A show the spell can cost A HP to monster in the common time. M show that when the monster’s HP <= M, using this spell can get double effect.

Input

The input contains multiple test cases.
Each test case include, first two integers n, m (2<n<10, 1<m<10^7), express how many spells yifenfei has.
Next n line , each line express one spell. (Ai, Mi).(0<Ai,Mi<=m).

Output

For each test case output one integer that how many spells yifenfei should use at least. If yifenfei can not kill the monster output -1.

Sample Input
3 100
10 20
45 89
5 40

3 100
10 20
45 90
5 40

3 100
10 20
45 84
5 40

Sample Output
3
2

-1


一道不算太难的深搜题目,题意就是一个人有N个技能去杀一个大BOSS,每个技能只能用一次,

技能有两个属性:伤害和暴击范围。

第二个暴击范围就是当BOSS血量低于这个数值时,伤害翻倍。

恩,就是这样,喵~

找最小步数,现场还原,即使不剪枝也能过,应该。。。


#include <iostream>
#include <string.h>
#include <algorithm>
using namespace std;
int n,hp,step;
bool vis[11];
struct Spell
{
    int sh,jx;
}spl[11];

void dfs(int hp,int stp)
{
    // 基本小剪枝,小剪一下
    if(stp>=step)    return;
    if(hp<=0)
    {
        if(step>stp)   step=stp;
        return;
    }

    int i;
    for(i=0;i<n;++i)
    {
        if(!vis[i])
        {
            vis[i]=1;
            // 判断是否能暴击
            if(hp<=spl[i].jx)    dfs(hp-2*spl[i].sh,stp+1);
            else    dfs(hp-spl[i].sh,stp+1);
            vis[i]=0;
        }
    }
}

int main()
{
    int i;
    while(cin>>n>>hp)
    {
        for(i=0;i<n;++i)
            cin>>spl[i].sh>>spl[i].jx;
        memset(vis,0,sizeof(vis));
        
        // 最多10个技能,所以step不可能大于10
        step=11;
        dfs(hp,0);

        if(step==11)    cout<<-1<<endl;
        else    cout<<step<<endl;
    }
    return 0;
}


ACM-DFS之Kill The Monster——hdu2616,布布扣,bubuko.com

ACM-DFS之Kill The Monster——hdu2616

原文:http://blog.csdn.net/lttree/article/details/23111411

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!