首页 > 其他 > 详细

Bad Hair Day(单调栈 )

时间:2015-11-14 23:20:39      阅读:501      评论:0      收藏:0      [点我收藏+]
Bad Hair Day
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 15941   Accepted: 5382

Description

Some of Farmer John‘s N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows‘ heads.

Each cow i has a specified height hi (1 ≤ hi ≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.

Consider this example:

        =
=       =
=   -   =         Cows facing right -->
=   =   =
= - = = =
= = = = = =
1 2 3 4 5 6

Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow‘s hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow‘s hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!

Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.

Input

Line 1: The number of cows, N.
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i.

Output

Line 1: A single integer that is the sum of c1 through cN.

Sample Input

6
10
3
7
4
12
2

Sample Output

5
代码:
#include<iostream>
#include<cstdio>
#include<stack>
#include<algorithm>
using namespace std;
typedef long long LL;
int main(){
    int n;
    while(~scanf("%d",&n)){
        stack<int>S;
        int t;
        scanf("%d",&t);
        S.push(t);
        LL ans=0;
        for(int i=1;i<n;i++){
            scanf("%d",&t);
            while(!S.empty()&&t>=S.top())S.pop();
            ans+=S.size();
            S.push(t);
        }
        printf("%lld\n",ans);
    }
    return 0;
}

 

Bad Hair Day(单调栈 )

原文:http://www.cnblogs.com/handsomecui/p/4965767.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!