首页 > 其他 > 详细

POJ 3261 Milk Patterns 求可重叠的 k 次最长重复子串(后缀数组)

时间:2014-04-08 23:31:20      阅读:626      评论:0      收藏:0      [点我收藏+]
Milk Patterns
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 9361   Accepted: 4218
Case Time Limit: 2000MS

Description

Farmer John has noticed that the quality of milk given by his cows varies from day to day. On further investigation, he discovered that although he can‘t predict the quality of milk from one day to the next, there are some regular patterns in the daily milk quality.

To perform a rigorous study, he has invented a complex classification scheme by which each milk sample is recorded as an integer between 0 and 1,000,000 inclusive, and has recorded data from a single cow over N (1 ≤ N≤ 20,000) days. He wishes to find the longest pattern of samples which repeats identically at least K (2 ≤ K ≤ N) times. This may include overlapping patterns -- 1 2 3 2 3 2 3 1 repeats 2 3 2 3 twice, for example.

Help Farmer John by finding the longest repeating subsequence in the sequence of samples. It is guaranteed that at least one subsequence is repeated at least K times.

Input

Line 1: Two space-separated integers: N and K 
Lines 2..N+1: N integers, one per line, the quality of the milk on day i appears on the ith line.

Output

Line 1: One integer, the length of the longest pattern which occurs at least K times

Sample Input

8 2
1
2
3
2
3
2
3
1

Sample Output

4

Source

给定一个字符串,求至少出现 k 次的最长重复子串,这 k 个子串可以重叠。
跟POJ1743差不多,都用二分求解,只不过这道题二分求解的是最长长度,每判断mid长度时,需要遍历一下所有的height数组,看看有没有最长公共前缀长度是mid而且数量大于k的,如果存在,则此mid满足条件,继续二分。
//4876K	172MS
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define M 20007
#define MAX 1000010
using namespace std;
int sa[MAX],rank[MAX],height[MAX];
int wa[MAX],wb[MAX],wv[MAX],ws[MAX];
int num[MAX],s[MAX];
int cmp(int *r,int a,int b,int l)
{
    return r[a]==r[b]&&r[a+l]==r[b+l];
}
void get_sa(int *r,int n,int m)//求get函数
{
    int i,j,p,*x=wa,*y=wb,*t;
    for(i=0; i<m; i++)ws[i]=0;
    for(i=0; i<n; i++)ws[x[i]=r[i]]++;
    for(i=1; i<m; i++)ws[i]+=ws[i-1];
    for(i=n-1; i>=0; i--)sa[--ws[x[i]]]=i;
    for(j=1,p=1; p<n; j*=2,m=p)
    {
        for(p=0,i=n-j; i<n; i++)y[p++]=i;
        for(i=0; i<n; i++)if(sa[i]>=j)y[p++]=sa[i]-j;
        for(i=0; i<n; i++)wv[i]=x[y[i]];
        for(i=0; i<m; i++)ws[i]=0;
        for(i=0; i<n; i++)ws[wv[i]]++;
        for(i=1; i<m; i++)ws[i]+=ws[i-1];
        for(i=n-1; i>=0; i--)sa[--ws[wv[i]]]=y[i];
        for(t=x,x=y,y=t,p=1,x[sa[0]]=0,i=1; i<n; i++)
            x[sa[i]]=cmp(y,sa[i-1],sa[i],j)?p-1:p++;
    }
}
void get_height(int *r,int n)//求height函数
{
    int i,j,k=0;
    for(i=1; i<=n; i++)rank[sa[i]]=i; //求rank函数
    for(i=0; i<n; height[rank[i++]]=k)
        for(k?k--:0,j=sa[rank[i]-1]; r[i+k]==r[j+k]; k++);
}
int solve(int n,int k)//二分求解最长长度
{
    int maxx=n,minn=1;
    while(minn<=maxx)
    {
        int mid=(minn+maxx)/2,count=1,flag=0;
        for(int i=2; i<=n; i++)
            if(height[i]<mid){count=1;}//如果最长公共前缀小于mid,那么count就得重新开始计数
            else
            {
                count++;
                if(count==k)//如果找到k个,说明此长度满足
                {
                    flag=1;break;
                }
            }
        if(flag){minn=mid+1;}
        else maxx=mid-1;
    }
    return maxx;
}
int main()
{
    //freopen("in.txt","r",stdin);
    int n,k;
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        for(int i=0; i<n; i++)
            scanf("%d",&num[i]);
        get_sa(num,n+1,MAX);
        get_height(num,n);
        printf("%d\n",solve(n,k));
    }
    return 0;
}



POJ 3261 Milk Patterns 求可重叠的 k 次最长重复子串(后缀数组),布布扣,bubuko.com

POJ 3261 Milk Patterns 求可重叠的 k 次最长重复子串(后缀数组)

原文:http://blog.csdn.net/crescent__moon/article/details/23208445

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!