首页 > 其他 > 详细

HDU 1071 The area (数学水题)

时间:2014-04-08 23:25:47      阅读:665      评论:0      收藏:0      [点我收藏+]

The area

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7088    Accepted Submission(s): 4975


Problem Description
Ignatius bought a land last week, but he didn‘t know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture, can you tell Ignatius the area of the land?

Note: The point P1 in the picture is the vertex of the parabola.

bubuko.com,布布扣

 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains three intersectant points which shows in the picture, they are given in the order of P1, P2, P3. Each point is described by two floating-point numbers X and Y(0.0<=X,Y<=1000.0).
 

Output
For each test case, you should output the area of the land, the result should be rounded to 2 decimal places.
 

Sample Input
2 5.000000 5.000000 0.000000 0.000000 10.000000 0.000000 10.000000 10.000000 1.000000 1.000000 14.000000 8.222222
 

Sample Output
33.33 40.69

题意:就是告诉图中三点坐标,求面积。


#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <climits>


typedef struct Point{
	double x,y;
}Point;

double a,b,c,k,d,s;
Point p[4];

double gao(double x){
	return (a/3.0*pow(x,3.0)+b/2.0*pow(x,2.0)+c*x-k/2*pow(x,2.0)-d*x);
}

int main(){

	//freopen("in.txt","r",stdin);
	int t,i;
	scanf("%d",&t);
	while(t--){
		for(i=1;i<=3;++i){
			scanf("%lf %lf",&p[i].x,&p[i].y);
		}
	
		a = (p[1].y-p[2].y)/(2*p[1].x*p[2].x-pow(p[2].x,2.0)-pow(p[1].x,2.0));
		b = -2*a*p[1].x;
		c = p[2].y+2*a*p[1].x*p[2].x-a*pow(p[2].x,2.0);
		k = (p[3].y-p[2].y)/(p[3].x-p[2].x);
		d = p[2].y-k*p[2].x;
		s = gao(p[3].x)-gao(p[2].x);
		printf("%0.2lf\n",s);
	}
	
    return 0;
}



HDU 1071 The area (数学水题),布布扣,bubuko.com

HDU 1071 The area (数学水题)

原文:http://blog.csdn.net/iaccepted/article/details/23207597

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!