首页 > 其他 > 详细

hdu 1597 find the nth digit

时间:2015-11-23 18:23:34      阅读:195      评论:0      收藏:0      [点我收藏+]

find the nth digit

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9836    Accepted Submission(s): 2881


Problem Description
假设:
S1 = 1
S2 = 12
S3 = 123
S4 = 1234
.........
S9 = 123456789
S10 = 1234567891
S11 = 12345678912
............
S18 = 123456789123456789
..................
现在我们把所有的串连接起来
S = 1121231234.......123456789123456789112345678912.........
那么你能告诉我在S串中的第N个数字是多少吗?
 

 

Input
输入首先是一个数字K,代表有K次询问。
接下来的K行每行有一个整数N(1 <= N < 2^31)。
 

 

Output
对于每个N,输出S中第N个对应的数字.
 

 

Sample Input
6
1
2
3
4
5
10
 

 

Sample Output
1
1
2
1
2
4
 
#include<stdio.h>  
#include<string.h>  
#include<algorithm>  
using namespace std;  
__int64 i,j,k,l,m,n,t;  
int main()  
{  
    scanf("%I64d",&k);  
    while(k--)  
    {  
        scanf("%I64d",&n);  
        for(i=1;;i++)  
        if(i*(i+1)/2>=n)  
        break;  
        m=n-i*(i-1)/2;  
        m%=9;  
        if(m==0)  
        m=9;  
        printf("%I64d\n",m);  
    }  
}  

  

hdu 1597 find the nth digit

原文:http://www.cnblogs.com/tonghao/p/4988947.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!