首页 > 其他 > 详细

POJ 2406 Power Strings 求连续重复字串(kmp)

时间:2014-04-09 18:03:14      阅读:533      评论:0      收藏:0      [点我收藏+]
Power Strings
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 29827   Accepted: 12456

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source


kmp的next数组具有此性质:一个串的最小循环节长度是len-next[len]。
如果len%(len-next[len])==0,那么这个字符串的最小周期就是:len/(len-next[len]).

//5248K	110MS
#include<stdio.h>
#include<string.h>
#define M 1000007
int next[M];
char pattern[M];
void pre(int len)
{
	int i = 0, j = -1;
	next[0] = -1;
	while(i != len)
	{
		if(j == -1 || pattern[i] == pattern[j])
			next[++i] = ++j;
		else
			j = next[j];
	}
}
int main()
{
    //freopen("in.txt","r",stdin);
    while(scanf("%s",pattern)!=EOF)
    {
        if(strcmp(pattern,".")==0)break;
        int len=strlen(pattern);
        pre(len);
        if(len%(len-next[len])==0)
            printf("%d\n",len/(len-next[len]));
        else printf("1\n");
    }
    return 0;
}


POJ 2406 Power Strings 求连续重复字串(kmp),布布扣,bubuko.com

POJ 2406 Power Strings 求连续重复字串(kmp)

原文:http://blog.csdn.net/crescent__moon/article/details/23256723

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!