首页 > 其他 > 详细

1032. Sharing (25)【链表】——PAT (Advanced Level) Practise

时间:2015-12-03 14:14:04      阅读:358      评论:0      收藏:0      [点我收藏+]

题目信息

1032. Sharing (25)

时间限制100 ms
内存限制65536 kB
代码长度限制16000 B

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, “loading” and “being” are stored as showed in Figure 1.

技术分享
            Figure 1
You are supposed to find the starting position of the common suffix (e.g. the position of “i” in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (<= 105), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output “-1” instead.

Sample Input 1:
11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010
Sample Output 1:
67890
Sample Input 2:
00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1
Sample Output 2:
-1

解题思路

map模拟链表

AC代码

#include <cstdio>
#include <map>
#include <vector>
using namespace std;
int main()
{
    int begin1, begin2, n, prev, next, r = -1;
    char ch;
    map<int, int> mp;
    scanf("%d%d%d", &begin1, &begin2, &n);
    while (n--){
        scanf("%d %*c %d", &prev, &next);
        mp[prev] = next;
    }
    vector<int> v1, v2;
    while (begin1 != -1){
        v1.push_back(begin1);
        begin1 = mp[begin1];
    }
    while (begin2 != -1){
        v2.push_back(begin2);
        begin2 = mp[begin2];
    }
    unsigned int end = 1;
    while (v1.size() >= end && v2.size() >= end && 
            v1[v1.size() - end] == v2[v2.size() - end]){
        ++end;
    }
    if (end != 1) printf("%05d\n", v1[v1.size() - end + 1]);
    else printf("-1\n");
    return 0;
}

1032. Sharing (25)【链表】——PAT (Advanced Level) Practise

原文:http://blog.csdn.net/xianyun2009/article/details/50154645

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!