首页 > 其他 > 详细

UVA 10943 How do you add? DP

时间:2015-12-24 19:16:22      阅读:182      评论:0      收藏:0      [点我收藏+]

Larry is very bad at math — he usually uses a calculator, which
worked well throughout college. Unforunately, he is now struck in
a deserted island with his good buddy Ryan after a snowboarding
accident.
They’re now trying to spend some time ?guring out some good
problems, and Ryan will eat Larry if he cannot answer, so his fate
is up to you!
It’s a very simple problem — given a number N, how many ways
can K numbers less than N add up to N?
For example, for N = 20 and K = 2, there are 21 ways:
0+20
1+19
2+18
3+17
4+16
5+15
...
18+2
19+1
20+0
Input
Each line will contain a pair of numbers N and K. N and K will both be an integer from 1 to 100,
inclusive. The input will terminate on 2 0’s.
Output
Since Larry is only interested in the last few digits of the answer, for each pair of numbers N and K,
print a single number mod 1,000,000 on a single line.
Sample Input
20 2
20 2
0 0
Sample Output
21
21

题意:  给你N,k  计算k个数相加等于N的方案数,    1,100  输出100

题解:设定dp[n][k]   dp[i][j] = ∑ dp[k][j - 1](0 ≤ k ≤ i)。

 

技术分享
//meek///#include<bits/stdc++.h>
#include <iostream>
#include <cstdio>
#include <cmath>
#include <string>
#include <cstring>
#include <algorithm>
#include <queue>
#include <map>
#include <set>
#include <stack>
#include <sstream>
#include <vector>
using namespace std ;
#define mem(a) memset(a,0,sizeof(a))
#define pb push_back
#define fi first
#define se second
#define MP make_pair
typedef long long ll;

const int N = 110;
const int inf = 99999999;
const int mod= 1000000007;

int dp[N][N]; //n//k
int n,k;
int main() {
    for(int i=0;i<=100;i++) dp[0][i] += 1;
    //for(int i=0;i<=100;i++) dp[i][1] += 1;
    for(int i=1;i<=100;i++) {
        for(int j=1;j<=100;j++) {
            for(int h=0;h<=i;h++)
              dp[i][j] += dp[h][j-1],dp[i][j] %=  1000000;
        }
    }
    while(~scanf("%d%d",&n,&k)) {
        if(n==0&&k==0) break;
        printf("%d\n",dp[n][k]);
    }
    return 0;
}
daima

 

UVA 10943 How do you add? DP

原文:http://www.cnblogs.com/zxhl/p/5073888.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!