首页 > 其他 > 详细

杭电acm 2952

时间:2014-04-14 01:51:42      阅读:384      评论:0      收藏:0      [点我收藏+]

Counting Sheep

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1902    Accepted Submission(s): 1244


Problem Description
A while ago I had trouble sleeping. I used to lie awake, staring at the ceiling, for hours and hours. Then one day my grandmother suggested I tried counting sheep after I‘d gone to bed. As always when my grandmother suggests things, I decided to try it out. The only problem was, there were no sheep around to be counted when I went to bed.
bubuko.com,布布扣


Creative as I am, that wasn‘t going to stop me. I sat down and wrote a computer program that made a grid of characters, where # represents a sheep, while . is grass (or whatever you like, just not sheep). To make the counting a little more interesting, I also decided I wanted to count flocks of sheep instead of single sheep. Two sheep are in the same flock if they share a common side (up, down, right or left). Also, if sheep A is in the same flock as sheep B, and sheep B is in the same flock as sheep C, then sheeps A and C are in the same flock.


Now, I‘ve got a new problem. Though counting these sheep actually helps me fall asleep, I find that it is extremely boring. To solve this, I‘ve decided I need another computer program that does the counting for me. Then I‘ll be able to just start both these programs before I go to bed, and I‘ll sleep tight until the morning without any disturbances. I need you to write this program for me.
 

Input
The first line of input contains a single number T, the number of test cases to follow.

Each test case begins with a line containing two numbers, H and W, the height and width of the sheep grid. Then follows H lines, each containing W characters (either # or .), describing that part of the grid.
 

Output
For each test case, output a line containing a single number, the amount of sheep flock son that grid according to the rules stated in the problem description.

Notes and Constraints
0 < T <= 100
0 < H,W <= 100
 

Sample Input
2 4 4 #.#. .#.# #.## .#.# 3 5 ###.# ..#.. #.###
 

Sample Output
6 3
#include <iostream>
#include <stdio.h>
using namespace std;
int map[105][105],dir[4][2]={{0,1},{0,-1},{1,0},{-1,0}},n,m;
bool fun(int i,int j)
{
    if(i>=0&&j>=0&&i<n&&j<m)
        return true;
    return false;
}
int dfs(int i,int j)
{

    map[i][j]=0;
    for(int ii=0;ii<4;ii++)
    {
        int x=i+dir[ii][0];
        int y=j+dir[ii][1];
         if(fun(x,y)&&map[x][y])
            dfs(x,y);
    }


   return 1;
}
int main()
{
    int t,i,j,sum;
    char str[100],c;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        getchar();
        for(i=0;i<n;i++)
        {


            for(j=0;j<m;j++)
            {
                if((c=getchar())==‘#‘)
                {
                    map[i][j]=1;
                }
                else if(c==‘.‘)
                {
                    map[i][j]=0;
                }

            }
            gets(str);
        }
        sum=0;
        for(i=0;i<n;i++)
            for(j=0;j<m;j++)
            {

                if(map[i][j])
                sum+=dfs(i,j);

            }
        printf("%d\n",sum);

    }
    return 0;
}


杭电acm 2952,布布扣,bubuko.com

杭电acm 2952

原文:http://blog.csdn.net/fanerxiaoqinnian/article/details/23619867

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!