首页 > 其他 > 详细

Joseph(约瑟夫环)

时间:2016-01-12 19:34:49      阅读:188      评论:0      收藏:0      [点我收藏+]

Joseph

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2094    Accepted Submission(s): 1273


Problem Description
The Joseph‘s problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.
 

 

Input
The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.
 

 

Output
The output file will consist of separate lines containing m corresponding to k in the input file.
 

 

Sample Input
3 4 0
 

 

Sample Output
5 30
题解:F(i)=(F(i-1)+m-1)%(n-i+1)由于去的后k个所以当F小于k就不符合。需要打表,否则超时;
代码:
#include<cstdio>
#include<cstring>
#include<cmath>
#include<iostream>
#include<algorithm>
using namespace std;
int k;
int dp[15];
bool solve(int m){
	int cur=0;
	for(int i=1;i<=k;i++){
		if((cur+m-1)%(2*k-i+1)<k)
			return false;
		cur=(cur+m-1)%(2*k-i+1);
	}
	return true;
}
int main(){
	for(k=1;k<15;k++){
		int i;
		for(i=1;;i++){
			if(solve(i))break;
		}
		dp[k]=i;
	}
	while(~scanf("%d",&k),k){
		printf("%d\n",dp[k]);
	}
	return 0;
}

 

Joseph(约瑟夫环)

原文:http://www.cnblogs.com/handsomecui/p/5125189.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!