首页 > 其他 > 详细

poj 1004 Financial Management

时间:2014-04-15 03:24:35      阅读:549      评论:0      收藏:0      [点我收藏+]
Financial Management
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 122613   Accepted: 55134

Description

Larry graduated this year and finally has a job. He‘s making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what‘s been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.

Input

The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.

Output

The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.

Sample Input

100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75

Sample Output

$1581.42

Source

我在昨天重做这个题,系统返回Wrong Answer,原来我最后一句写的是printf("$%.2lf\n",tot/12.0); 按照严格的C语言,prinf是不能使用"%lf"来输出的,float或者double的输出都应写作"%f",只是有很多编译器为了兼容性,擅自支持了"%lf"的输出格式。作为在ACM搞了一年多的人,对一些语言问题竟全然不知,可见我平时的学习是不够细致的。

#include<iostream>
#include<cstdio>
int main()
{
    double a[12],s=0;
    int i;
    for(i=0;i<12;i++)
    {
        scanf("%lf",&a[i]);
        s=s+a[i];
    }
    printf("$%.2f",s/12);
}


poj 1004 Financial Management,布布扣,bubuko.com

poj 1004 Financial Management

原文:http://blog.csdn.net/fanerxiaoqinnian/article/details/23712077

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!