Problem Description
We once did a lot of recursional problem . I think some of them is easy for you and some if hard for you.
Now there is a very easy problem . I think you can AC it.
We can define sum(n) as follow:
if i can be divided exactly by 3 sum(i) = sum(i-1) + i*i*i;else sum(i) = sum(i-1) + i;
Is it very easy ? Please begin to program to AC it..-_-
Input
The input file contains multilple cases.
Every cases contain only ont line, every line contains a integer n (n<=100000).
when n is a negative indicate the end of file.
Output
output the result sum(n).
Sample Input
Sample Output
很容易想到先递推打表,有个坑,i也要用64位,不然i*i*i会溢出,需要特别注意。
#include<stdio.h>
#include<string.h>
__int64 f[100005],i,n; //i也要64位
int main()
{
memset(f,0,sizeof(f));
f[1]=1;
for(i=2; i<=100002; i++)
if(i%3==0) f[i]=f[i-1]+i*i*i;
else f[i]=f[i-1]+i;
while(~scanf("%I64d",&n) && n>=0) {
printf("%I64d\n",f[n]);
}
return 0;
}
HDU 2132 An easy problem,布布扣,bubuko.com
HDU 2132 An easy problem
原文:http://blog.csdn.net/u013923947/article/details/23782079