首页 > 其他 > 详细

【poj3070】Fibonacci

时间:2016-01-30 22:37:26      阅读:158      评论:0      收藏:0      [点我收藏+]

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

技术分享.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

HINT

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

技术分享.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

技术分享.

Source

 
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
void mul(int a[2][2],int b[2][2]){
    int c[2][2];
    memset(c,0,sizeof(c));
    for (int i=0;i<2;i++)
        for (int j=0;j<2;j++)
            for (int k=0;k<2;k++){
                c[i][j]=(c[i][j]+a[i][k]*b[k][j])%10000;
            }
    memcpy(a,c,sizeof(c));
}
int main(){
    int n;
    while (cin>>n && n!=-1){
        int a[2][2]={{0,1},{1,1}};
        int f[2][2]={{0,1},{0,0}};
        while (n>0){
            if (n&1) mul(f,a);
            mul(a,a);
            n>>=1;
        }
        cout<<f[0][0]<<endl;
    }
    return 0;
}

 

【poj3070】Fibonacci

原文:http://www.cnblogs.com/liumengyue/p/5172034.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!