首页 > 其他 > 详细

poj1163(数字三角形)

时间:2014-04-21 06:23:09      阅读:563      评论:0      收藏:0      [点我收藏+]

The Triangle
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30
大水题,汝佳大神白书上有原题,转移方程
dp[i][j]=max(dp[i+1][j],dp[i+1][j+1])+A[i][j];

代码如下

#include <stdio.h>
#include<algorithm>
#include<cstring>
int dp[101][101],A[101][101];
using std::max;
int main()
{
    //freopen("input.txt","r",stdin);
    int n;
    while(~scanf("%d",&n))
    {
        memset(dp,0,sizeof(dp));
        for(int j=1;j<=n;j++)
        for(int i=1;i<=j;i++)
        scanf("%d",&A[j][i]);
        for(int i=1;i<=n;i++)
            dp[n][i]=A[n][i];
        for(int i=n-1;i>=1;i--)
        for(int j=1;j<=i;j++)
        dp[i][j]=max(dp[i+1][j],dp[i+1][j+1])+A[i][j];
        printf("%d\n",dp[1][1]);
    }
    return 0;
}



poj1163(数字三角形),布布扣,bubuko.com

poj1163(数字三角形)

原文:http://blog.csdn.net/acvcla/article/details/24192055

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!