首页 > 其他 > 详细

hdu-5645 DZY Loves Balls(水题)

时间:2016-03-20 00:34:23      阅读:342      评论:0      收藏:0      [点我收藏+]

题目链接:

DZY Loves Balls

Time Limit: 4000/2000 MS (Java/Others)   

 Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 105    Accepted Submission(s): 75


Problem Description
DZY loves playing balls.

He has n balls in a big box. On each ball there is an integer written.

One day he decides to pick two balls from the box. First he randomly picks a ball from the box, and names it A. Next, without putting A back into the box, he randomly picks another ball from the box, and names it B.

If the number written on A is strictly greater than the number on B, he will feel happy.

Now you are given the numbers on each ball. Please calculate the probability that he feels happy.
 

 

Input
First line contains t denoting the number of testcases.

t testcases follow. In each testcase, first line contains n, second line contains n space-separated positive integers ai, denoting the numbers on the balls.

(1t300,2n300,1ai300)
 

 

Output
For each testcase, output a real number with 6 decimal places. 
 

 

Sample Input
2
3
1 2 3
3
100 100 100
 

 

Sample Output
0.500000
0.000000
AC代码:
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
int a[600];
int main()
{
    int t,n,k;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }
        double ans=0;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                if(i!=j)
                {
                    if(a[j]<a[i])
                    ans+=1/(n*(n-1)*1.0);
                }
            }
        }
        printf("%.6lf\n",ans);
    }
    return 0;
}

 

hdu-5645 DZY Loves Balls(水题)

原文:http://www.cnblogs.com/zhangchengc919/p/5296602.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!