首页 > 其他 > 详细

UVa - 494 - Kindergarten Counting Game 题解

时间:2014-04-22 18:19:10      阅读:504      评论:0      收藏:0      [点我收藏+]

Everybody sit down in a circle. Ok. Listen to me carefully.

``Woooooo, you scwewy wabbit!‘‘

Now, could someone tell me how many words I just said?

Input and Output

Input to your program will consist of a series of lines, each line containing multiple words (at least one). A ``word‘‘ is defined as a consecutive sequence of letters (upper and/or lower case).

Your program should output a word count for each line of input. Each word count should be printed on a separate line.

Sample Input

Meep Meep!
I tot I taw a putty tat.
I did! I did! I did taw a putty tat.
Shsssssssssh ... I am hunting wabbits. Heh Heh Heh Heh ...

Sample Output

2
7
10
9

这里的题目有点不太清楚,因为有一种情况我开始也忽视了:

jfle..............ioo89839jji

这里其实是算3个单词,算成一个单词就错了。

还有就是注意处理行间信息

#include <string>
#include <iostream>
using namespace std;

bool mIsAlpha(char a)
{
	return ‘a‘ <= a && a <= ‘z‘ || ‘A‘ <= a && a <= ‘Z‘;
}

void KindergartenCountingGame()
{
	string s;
	while (getline(cin, s))
	{
		int c = 0;
		bool sp = true;
		for (int i = 0, j = 0; i < s.size(); i++)
		{
			if (!mIsAlpha(s[i])) sp = true;
			else if (sp && mIsAlpha(s[i]))
			{
				c++;
				sp = false;
			}
		}
		cout<<c<<endl;
	}
}





UVa - 494 - Kindergarten Counting Game 题解,布布扣,bubuko.com

UVa - 494 - Kindergarten Counting Game 题解

原文:http://blog.csdn.net/kenden23/article/details/24309689

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!