首页 > 其他 > 详细

2012年浙大:Hello World for U

时间:2016-03-24 20:25:31      阅读:369      评论:0      收藏:0      [点我收藏+]
题目描述:

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h    d
e     l
l      r
lowo


That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

输入:

There are multiple test cases.Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

输出:

For each test case, print the input string in the shape of U as specified in the description.

样例输入:
helloworld!
ac.jobdu.com
样例输出:
h   !
e   d
l   l
lowor
a    m
c    o
.    c
jobdu.

题目来源:http://ac.jobdu.com/problem.php?pid=1464


#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char s[100];
int main()
{
    while(scanf("%s",s)!=EOF)//gets WA
    {
        int len=strlen(s);
        int n1=max(min((len-1)/2,(len+2)/3),1);
        n1--;
        int n2=len-n1*2;
        for(int i=0;i<n1;i++)
        {
            printf("%c",s[i]);
            for(int j=0;j<n2-2;j++)
            {
                printf(" ");
            }
            printf("%c\n",s[len-i-1]);
        }
        for(int i=n1;i<len-n1;i++)
        {
            printf("%c",s[i]);
        }
        printf("\n");
    }
    
    return 0;
}

 

2012年浙大:Hello World for U

原文:http://www.cnblogs.com/program-ccc/p/5316888.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!