首页 > 其他 > 详细

Max Sum

时间:2016-03-29 21:14:31      阅读:127      评论:0      收藏:0      [点我收藏+]

题目来源:赛马网(Max Sum)

Problem Description

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6
#include <stdio.h>
#include <string.h>
#define MAXLEN 100001
const int MIN = -1000;
int num[MAXLEN];
int main()
{
    int caseN;
    while (scanf("%d", &caseN) != EOF)
    {
        int cas = 0;
        while (caseN--)
        {
            int n;
            int tmp = 1;
            int s = 0, e = 0;
            int sumMax = MIN;
            num[0] = 0;
            scanf("%d", &n);
            for (int i = 1; i <= n; i++)
            {
                scanf("%d", &num[i]);
                num[0] += num[i];
                if (num[0] > sumMax)
                {
                    sumMax = num[0];
                    s = tmp;
                    e = i;
                }

                if (num[0] < 0 )
                {
                    num[0] = 0;
                    tmp = i + 1;
                }
            }
            cas++;
            printf("Case %d:\n",cas);
            printf("%d %d %d\n", sumMax,s,e);
            if (caseN)
                printf("\n");
        }

    }
    return 0;
}

 

Max Sum

原文:http://www.cnblogs.com/tgycoder/p/5334313.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!