首页 > 其他 > 详细

HDU 2147 —— kiki's game

时间:2016-04-08 21:51:54      阅读:327      评论:0      收藏:0      [点我收藏+]

kiki‘s game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 40000/10000 K (Java/Others)

Problem Description
Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can‘t make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?
 
Input
Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.

Output
If kiki wins the game printf "Wonderful!", else "What a pity!".
 
Sample Input
5 3
5 4
6 6
0 0
 
Sample Output
What a pity!
Wonderful!
Wonderful!
 
#include <cstdio>
#include <iostream>

using namespace std;

const int MAXN = 2000 + 5;

bool dp[MAXN][MAXN];

void Init()
{
    for(int i=0; i<MAXN; i++)    dp[0][i] = dp[i][0] = 1;
    
    for(int i=1; i<MAXN; i++) {
        for(int j=1; j<MAXN; j++) {
            dp[i][j] = !(dp[i-1][j] && dp[i-1][j-1] && dp[i][j-1]);
        }
    }
}

int main ()
{
    Init();int n, m;
    while(~scanf("%d%d", &n, &m) && (m|n)) {
        printf("%s\n", dp[n][m]?"Wonderful!":"What a pity!");        
    }
    
    return 0;
}

 

HDU 2147 —— kiki's game

原文:http://www.cnblogs.com/AcIsFun/p/5369958.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!