首页 > 其他 > 详细

NYOJ 715 Adjacent Bit Counts

时间:2014-04-24 15:50:50      阅读:615      评论:0      收藏:0      [点我收藏+]

Adjacent Bit Counts

时间限制:1000 ms  |  内存限制:65535 KB
难度:4
描述

For a string of n bits x1, x2, x3, …, xn,  the adjacent bit count of the string  is given by     fun(x) = x1*x2 + x2*x3 + x3*x 4 + … + xn-1*x n
which counts the number of times a 1 bit is adjacent to another 1 bit. For example:  

     Fun(011101101) = 3

     Fun(111101101) = 4

     Fun (010101010) = 0

Write a program which takes as input integers n and p and returns the number of bit strings x of n bits (out of 2?) that satisfy  Fun(x) = p.

 

For example, for 5 bit strings, there are 6 ways of getting fun(x) = 2:

11100, 01110, 00111, 10111, 11101, 11011

输入
On the first line of the input is a single positive integer k, telling the number of test cases to follow. 1 ≤ k ≤ 10 Each case is a single line that contains a decimal integer giving the number (n) of bits in the bit strings, followed by a single space, followed by a decimal integer (p) giving the desired adjacent bit count. 1 ≤ n , p ≤ 100
输出
For each test case, output a line with the number of n-bit strings with adjacent bit count equal to p.
样例输入
2
5 2
20 8 
样例输出
6
63426
动态规划!
AC码:
#include<stdio.h>
#include<string.h>
long long dp[105][105][2];
void fun()
{
	int i,j;
	memset(dp,0,sizeof(dp));
	dp[1][0][0]=1;
	dp[1][0][1]=1;
	for(i=2;i<=100;i++)
	{
		dp[i][0][0]=dp[i-1][0][0]+dp[i-1][0][1];
		dp[i][0][1]=dp[i-1][0][0];
		dp[i][i-1][1]=1;
	}
	for(j=1;j<=100;j++)
	{
		for(i=j+2;i<=100;i++)
		{
			dp[i][j][0]=dp[i-1][j][0]+dp[i-1][j][1];
			dp[i][j][1]=dp[i-1][j][0]+dp[i-1][j-1][1];
		}
	}
}
int main()
{
	int T,n,p;
	fun();
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d",&n,&p);
		printf("%lld\n",dp[n][p][0]+dp[n][p][1]);
	}
	return 0;
}


NYOJ 715 Adjacent Bit Counts,布布扣,bubuko.com

NYOJ 715 Adjacent Bit Counts

原文:http://blog.csdn.net/u012804490/article/details/24362843

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!