首页 > 其他 > 详细

HDU 2132 An easy problem

时间:2014-04-24 13:16:32      阅读:549      评论:0      收藏:0      [点我收藏+]

Problem Description
We once did a lot of recursional problem . I think some of them is easy for you and some if hard for you.
Now there is a very easy problem . I think you can AC it.
  We can define sum(n) as follow:
  if i can be divided exactly by 3 sum(i) = sum(i-1) + i*i*i;else sum(i) = sum(i-1) + i;
  Is it very easy ? Please begin to program to AC it..-_-
 

Input
  The input file contains multilple cases.
  Every cases contain only ont line, every line contains a integer n (n<=100000).
  when n is a negative indicate the end of file.
 

Output
  output the result sum(n).
 

Sample Input
1 2 3 -1
 

Sample Output
1 3 30

题目没什么好说的,思路很简单,打表。注意一个问题:i*i*i 可能会超int ,所以 i 必须定义 long long 。


#include<stdio.h>
#include<string.h>
__int64 f[100005],i,n;
int main()
{
    memset(f,0,sizeof(f));
    f[1]=1;
    for(i=2; i<=100002; i++)
        if(i%3==0) f[i]=f[i-1]+i*i*i;    //此处 i 必须是__int64,不然会WA
        else f[i]=f[i-1]+i;
    while(~scanf("%I64d",&n) && n>=0) {
        printf("%I64d\n",f[n]);
    }
    return 0;
}




HDU 2132 An easy problem,布布扣,bubuko.com

HDU 2132 An easy problem

原文:http://blog.csdn.net/u013923947/article/details/24362439

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!