首页 > 其他 > 详细

poj 2485 Highways

时间:2014-04-26 03:06:58      阅读:537      评论:0      收藏:0      [点我收藏+]

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 20757   Accepted: 9601

Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They‘re planning to build some highways so that it will be possible to drive between any pair of towns without leaving the highway system. 

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways. 

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.

Input

The first line of input is an integer T, which tells how many test cases followed. 
The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between village i and village j. There is an empty line after each test case.

Output

For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.

Sample Input

1

3
0 990 692
990 0 179
692 179 0

Sample Output

692

Hint

Huge input,scanf is recommended.

还是最小生成树、prim。

至于输出最长的一条连通边,只要保证总长度最小,最长边一定最小。

#include"stdio.h"
#include"string.h"
#include"math.h"
#define N 505
#define inf 100000
int map[N][N],mark[N],dis[N];
int prim(int n)
{
	int i,index,min,max=0;
	for(i=0;i<n;i++)
		dis[i]=map[0][i];
	memset(mark,0,sizeof(mark));
	mark[0]=1;
	while(1)
	{
		index=-1;
		min=inf;
		for(i=0;i<n;i++)
			if(!mark[i]&&dis[i]<min)
			{
				min=dis[i];
				index=i;
			}
		if(index==-1)
			return max;
		mark[index]=1;
		if(max<min)
			max=min;
		for(i=0;i<n;i++)
			if(!mark[i]&&dis[i]>map[index][i])
				dis[i]=map[index][i];
	}
	return max;
}
int main()
{
	int T,i,j,n;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&n);
		for(i=0;i<n;i++)
			for(j=0;j<n;j++)
				scanf("%d",&map[i][j]);
		printf("%d\n",prim(n));
	}
	return 0;
}





poj 2485 Highways,布布扣,bubuko.com

poj 2485 Highways

原文:http://blog.csdn.net/u011721440/article/details/24496595

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!