首页 > Web开发 > 详细

POJ2531:Network Saboteur

时间:2016-06-29 18:36:55      阅读:218      评论:0      收藏:0      [点我收藏+]
Network Saboteur
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 10978   Accepted: 5290

Description

A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts. 
A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks. 
Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him. 
The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B).

Input

The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000). 
Output file must contain a single integer -- the maximum traffic between the subnetworks. 

Output

Output must contain a single integer -- the maximum traffic between the subnetworks.

Sample Input

3
0 50 30
50 0 40
30 40 0

Sample Output

90

方法1:不是在集合A就是在集合B,一一枚举尝试。
#include <cstdio>
#include <cstring>
using namespace std;
const int MAXN=25;
int c[MAXN][MAXN];
int n;
int res;
int unit[MAXN];
void dfs(int dep)
{
    if(dep==n)
    {
        int ans=0;
        for(int i=0;i<n;i++)
            for(int j=0;j<i;j++)
                if(unit[i]!=unit[j])
                {
                    ans+=c[i][j];
                }
        if(ans>res)    res=ans;
        return ;
    }
    unit[dep]=0;
    dfs(dep+1);
    unit[dep]=1;
    dfs(dep+1);
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        res=0;
        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
                scanf("%d",&c[i][j]);
        dfs(0);
        printf("%d\n",res);
    }
    return 0;
}

方法2:参考别人的代码,很巧妙地DFS。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int MAXN=25;
int n;
int belong[MAXN];
int c[MAXN][MAXN];
int res;
void dfs(int dep,int data)
{
    belong[dep]=1;
    int tmp=data;
    for(int i=0;i<n;i++)
    {
        if(belong[i]==0)
            tmp+=c[i][dep];
        else
            tmp-=c[i][dep];
    }
    if(tmp>res)    res=tmp;
    for(int i=dep+1;i<n;i++)
    {
        dfs(i,tmp);
        belong[i]=0;
    }
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        res=0;
        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
                scanf("%d",&c[i][j]);
        dfs(0,0);
        printf("%d\n",res);
    }
    return 0;
}

 

POJ2531:Network Saboteur

原文:http://www.cnblogs.com/program-ccc/p/5627648.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!