首页 > 其他 > 详细

ACM--三角形重心--HDOJ 2105--The Center of Gravity--水

时间:2016-08-02 19:24:50      阅读:466      评论:0      收藏:0      [点我收藏+]


HDOJ题目地址:传送门


The Center of Gravity

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5570    Accepted Submission(s): 3179


Problem Description
Everyone know the story that how Newton discovered the Universal Gravitation. One day, Newton walked 
leisurely, suddenly, an apple hit his head. Then Newton discovered the Universal Gravitation.From then
on,people have sovled many problems by the the theory of the Universal Gravitation. What‘s more, wo also
have known every object has its Center of Gravity.
Now,you have been given the coordinates of three points of a triangle. Can you calculate the center 
of gravity of the triangle?
 

Input
The first line is an integer n,which is the number of test cases.
Then n lines follow. Each line has 6 numbers x1,y1,x2,y2,x3,y3,which are the coordinates of three points.
The input is terminated by n = 0.
 

Output
For each case, print the coordinate, accurate up to 1 decimal places.
 

Sample Input
2 1.0 2.0 3.0 4.0 5.0 2.0 1.0 1.0 4.0 1.0 1.0 5.0 0
 

Sample Output
3.0 2.7 2.0 2.3
 



#include<iostream>
#include<stdio.h>
using namespace std;
int main(){
    int n;
    while(scanf("%d",&n)&&n){
         double x1,x2,x3,y1,y2,y3;
        while(n--){
            cin>>x1>>y1>>x2>>y2>>x3>>y3;
            printf("%.1lf %.1lf\n",(x1+x2+x3)/3,(y1+y2+y3)/3);
        }
    }
}



ACM--三角形重心--HDOJ 2105--The Center of Gravity--水

原文:http://blog.csdn.net/qq_26891045/article/details/52096228

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!