首页 > 其他 > 详细

POJ3211 Washing Clothes[DP]

时间:2016-08-24 11:10:01      阅读:206      评论:0      收藏:0      [点我收藏+]
Washing Clothes
Time Limit: 1000MS   Memory Limit: 131072K
Total Submissions: 9707   Accepted: 3114

Description

Dearboy was so busy recently that now he has piles of clothes to wash. Luckily, he has a beautiful and hard-working girlfriend to help him. The clothes are in varieties of colors but each piece of them can be seen as of only one color. In order to prevent the clothes from getting dyed in mixed colors, Dearboy and his girlfriend have to finish washing all clothes of one color before going on to those of another color.

From experience Dearboy knows how long each piece of clothes takes one person to wash. Each piece will be washed by either Dearboy or his girlfriend but not both of them. The couple can wash two pieces simultaneously. What is the shortest possible time they need to finish the job?

Input

The input contains several test cases. Each test case begins with a line of two positive integers M and N (M < 10, N < 100), which are the numbers of colors and of clothes. The next line contains M strings which are not longer than 10 characters and do not contain spaces, which the names of the colors. Then follow N lines describing the clothes. Each of these lines contains the time to wash some piece of the clothes (less than 1,000) and its color. Two zeroes follow the last test case.

Output

For each test case output on a separate line the time the couple needs for washing.

Sample Input

3 4
red blue yellow
2 red
3 blue
4 blue
6 red
0 0

Sample Output

10

Source

-------------------------------------------------------
每种颜色相互独立,单独求解加起来即可(好像矩阵取数)
 
对于一种颜色,平均分配,假设时间和为sum,就是给一个容量为sum/2的背包装东西,v和w都是时间(有点类似01背包可行性,但不一定装满,所以要保存w而不是1)
这样背包的价值就是一个人的用时,另一个人的用时是sum-背包价值,更新ans即可
[注意:和搭建双塔不同,本题一定要用所有“物品”,所以不用那么麻烦]
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <map>
#include <string>
using namespace std;
const int N=105,M=15,T=1e5+5;
int m,n,num=0,cnt[M],ans=0;
string s;
map<string,int> mp;
struct clo{
    int t,col;
}a[N];
int f[T];
void dp(){
    for(int c=1;c<=m;c++){
        int sum=cnt[c];
        memset(f,0,sizeof(f));
        for(int i=1;i<=n;i++) if(a[i].col==c)
            for(int j=sum/2;j>=a[i].t;j--)
                f[j]=max(f[j],f[j-a[i].t]+a[i].t);
        ans+=cnt[c]-f[sum/2];
    }
}
void init(){
    mp.clear();
    num=ans=0;
    memset(cnt,0,sizeof(cnt));
}
int main(){
    while(true){
    scanf("%d%d",&m,&n);
    if(m==0&&n==0) break;
    init();
    for(int i=1;i<=m;i++){
        cin>>s;
        mp[s]=++num;
    }
    for(int i=1;i<=n;i++){
        scanf("%d",&a[i].t);
        cin>>s;
        a[i].col=mp[s];
        cnt[a[i].col]+=a[i].t;
    }
    dp();
    printf("%d\n",ans);
    }
}

 

 
 

POJ3211 Washing Clothes[DP]

原文:http://www.cnblogs.com/candy99/p/5801890.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!