首页 > 其他 > 详细

POJ 1936

时间:2016-08-26 10:18:44      阅读:161      评论:0      收藏:0      [点我收藏+]

Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

Output

For each test case output "Yes", if s is a subsequence of t,otherwise output "No".

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No


#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>
#include<string.h>
typedef long long ll;
#define N 100005
using namespace std;
char str1[N];
char str2[N];
int main()
{
    int len1,len2;
    int i,j;
    while(cin>>str1>>str2)
    {
        len1=strlen(str1);
        len2=strlen(str2);
        int p=0;
        int t=0;
        for(i=0;i<len1;i++)
        {
            for(j=p;j<len2;j++)
            {
                if(str1[i]==str2[j])
                {
                    t++;
                    p=j+1;
                    break;
                }
            }
            if(j>=len2)
                break;
        }
        if(t==len1)
            printf("Yes\n");
        else
            printf("No\n");
    }
}

 

POJ 1936

原文:http://www.cnblogs.com/Aa1039510121/p/5809209.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!