首页 > 其他 > 详细

poj1426

时间:2016-08-31 20:24:02      阅读:251      评论:0      收藏:0      [点我收藏+]
Find The Multiple
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 27177   Accepted: 11309   Special Judge

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

Source

题解:
题目的意思就是给你一个数n,让你找到一个它的倍数只由1和0组成。(任何一个都可以,Special Judge)
AC代码:(c++)
#include<cstdio>
using namespace std;
int n,flag;
void go(long long p,int k){
    if(flag||k==20) return ;
    if(p%n==0){
        printf("%I64u\n",p);
        flag=1;
    }
    else{
        go(p*10,k+1);
        go(p*10+1,k+1);
    }
}
int main(){
    for(scanf("%d",&n);n;scanf("%d",&n)) flag=0,go(1,1);
    return 0;
}

 

poj1426

原文:http://www.cnblogs.com/shenben/p/5827316.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!