首页 > 其他 > 详细

find the nth digit

时间:2016-10-25 02:36:07      阅读:149      评论:0      收藏:0      [点我收藏+]

find the nth digit

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 880 Accepted Submission(s): 325
 
Problem Description
假设:
S1 = 1
S2 = 12
S3 = 123
S4 = 1234
.........
S9 = 123456789
S10 = 1234567891
S11 = 12345678912
............
S18 = 123456789123456789
..................
现在我们把所有的串连接起来
S = 1121231234.......123456789123456789112345678912.........
那么你能告诉我在S串中的第N个数字是多少吗?
 
Input
输入首先是一个数字K,代表有K次询问。
接下来的K行每行有一个整数N(1 <= N < 2^31)。
 
Output
对于每个N,输出S中第N个对应的数字.
 
Sample Input
6
1
2
3
4
5
10
 
Sample Output
1
1
2
1
2
4
 
Author
8600
 
Source
HDU 2007-Spring Programming Contest - Warm Up (1)
 
Recommend
8600
 
/*
加到S65536长度就大于2^31了
*/
#include<bits/stdc++.h>
using namespace std;
int main()
{
    //freopen("C:\\Users\\acer\\Desktop\\in.txt","r",stdin);
    long long n,t;
    scanf("%lld",&t);
    while(t--)
    {
        scanf("%lld",&n);
        long long i;
        long long s=0;
        for(i=1;s<n;i++)
            s+=i;
        long long cur=n-s+i-1;
        if(cur%9)
            printf("%d\n",cur%9);
        else
            puts("9");
    }
}

 

find the nth digit

原文:http://www.cnblogs.com/wuwangchuxin0924/p/5995169.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!