首页 > 其他 > 详细

HDOJ 4006 The kth great number

时间:2014-05-23 08:15:48      阅读:388      评论:0      收藏:0      [点我收藏+]

The kth great number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 6240    Accepted Submission(s): 2532


Problem Description
Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.
 

Input
There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number. 
 

Output
The output consists of one integer representing the largest number of islands that all lie on one line. 
 

Sample Input
8 3 I 1 I 2 I 3 Q I 5 Q I 4 Q
 

Sample Output
1 2 3
Hint
Xiao Ming won‘t ask Xiao Bao the kth great number when the number of the written number is smaller than k. (1=<k<=n<=1000000).
思路:优先队列+贪心
#include<stdio.h>
#include<iostream>
#include<queue>
using namespace std;
int main()
{
  
   int m,n,i,a;
   char c;
   priority_queue<int, vector<int>, greater<int> >que;
   while(cin>>m>>n)
   {
     while(!que.empty())
     {
     que.pop();
     }
    for(i=0;i<m;i++)
   {
     cin>>c;
     if(c==‘I‘) 
     {
       cin>>a;
       que.push(a);
       if(que.size()>n)
         que.pop();
     }
      else if(c==‘Q‘)
      {
        cout<<que.top()<<endl;
      }           
   }
  }
   system("pause");
   return 0;
}



HDOJ 4006 The kth great number,布布扣,bubuko.com

HDOJ 4006 The kth great number

原文:http://blog.csdn.net/an327104/article/details/26229785

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!