首页 > Web开发 > 详细

安装openstack时apache无法启动

时间:2017-01-12 16:08:58      阅读:146      评论:0      收藏:0      [点我收藏+]

标签:pyscss   apache   python   error   

 安装openstack-dashboard时出现的python compresscommand not found错误 httpd服务启动失败

 

 出现如下的报错信息:

 python[xxxxx]: CommandError: An error occurred during rendering 

 /usr/share/openstack-dashboard/openstack_dashboard/templates/_stylesheets.html: 

 /bin/sh: django_pyscss.compressor.DjangoScssFilter: command not found

 

 centos7 中的python版本为2.7

 

 django-pyscss的版本为要在2.0以上才能正常使用,而自带版本为:

 # yum list|grep django-pyscss

[email protected]


所以需要更新django-pyscss版本,过程如下:


1.首先把1.0.5版本去掉,使用pip安装2.0.2版本


# cd /usr/lib/python2.7/site-packages/

# mv django_pyscss-1.0.5-py2.7.egg-info django_pyscss-1.0.5-py2.7.egg-info_bak


如果系统中有pip 则正常安装并进行查看


# pip install django-pyscss==2.0.2

# pip list|grep pyscss

django-pyscss (2.0.2)


我的系统中没有安装pip

安装pip时setup.py中使用setuptools中的模块,但是电脑中并没有安装setuptools软件包,所以

我们需要先下载并安装 setuptools!


(1)下载setuptools包

# wget http://pypi.python.org/packages/source/s/setuptools/setuptools-2.0.tar.gz

(2)解压setuptools包

# tar zxvf setuptools-2.0.tar.gz

# cd setuptools-2.0

(3)编译setuptools

# python setup.py build

(4)开始执行setuptools安装

# python setup.py install


安装pip


# tar -xvf pip-1.4.1.tar.gz  

# cd pip-1.4.1/  

# python setup.py install  


本文出自 “纷繁中享受技术的简单喜悦” 博客,请务必保留此出处http://51enjoy.blog.51cto.com/8393791/1891410

安装openstack时apache无法启动

标签:pyscss   apache   python   error   

原文:http://51enjoy.blog.51cto.com/8393791/1891410

(0)
(0)
   
举报
评论 一句话评论(0
0条  
登录后才能评论!
© 2014 bubuko.com 版权所有 鲁ICP备09046678号-4
打开技术之扣,分享程序人生!
             

鲁公网安备 37021202000002号