首页 > 其他 > 详细

calculate the sum of some integers

时间:2014-05-23 06:41:25      阅读:504      评论:0      收藏:0      [点我收藏+]

Description

Your task is to calculate the sum of some integers.

Input

Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

Output

For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

Sample Input

2
4 1 2 3 4
5 1 2 3 4 5

Sample Output

10
bubuko.com,布布扣
#include<iostream>
using namespace std;


int main()
{
    int N1=0,x=0;
    int **arrayN;
    cin>>N1;
    arrayN=new int*[N1];
    for(int i=0;i<N1;i++)
    {
        cin>>x;
        arrayN[i]=new int [x+1];
        for(int j=1;j<x+1;j++)
        {
            cin>>arrayN[i][j];
        }
        arrayN[i][0]=x;
    }

    int *sum=new int [N1];
    for(int i=0;i<N1;i++)
    {
        sum[i]=0;
    }
    for(int i=0;i<N1;i++)
    {
        int k=arrayN[i][0];
        for(int j=1;j<k+1;j++)
        {
            sum[i]+=arrayN[i][j];
        }
    }
    for(int i=0;i<N1;i++)
    {
        cout<<sum[i]<<endl;
    }
    return 0;
}
bubuko.com,布布扣

 

 

calculate the sum of some integers,布布扣,bubuko.com

calculate the sum of some integers

原文:http://www.cnblogs.com/brock-1993/p/3741683.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!